Jump to content
Sign in to follow this  
seesthru

Sound effects

Recommended Posts

Hi,

I've split this page of replies off from the Luther topic.

I took a look at the source code of the posts where you've tried the Ouro buttons on the editor and it says your browser doesn't support it, that's actually a bit false positive, that message is a fallback if the player doesn't show.

It looks like the playback controls are being stripped out after you post, because as a non-admin member, you can't post raw HTML (for security reasons) which was something I didn't consider when trying to come up with a sort of alternative workaround designed to reduce the 'no boom' posts clogging up the Chatbox.

If you can see the player when I've posted a boom, that's a good sign. I'll try whitelisting the relevant html5 audio tags in the editor and see if it fixes it for you. There are some areas of the site where it may show that message but it should work in forum posts.

Share this post


Link to post
Share on other sites

It's okay, I downloaded the boom boom.  LOL!

Earthnut, so far, there's only one sound that plays from the MLM theme, and it's not even one I recognize.  I'll have to look at it some more.

Share this post


Link to post
Share on other sites

Old Man, I am totally confused, and so glad you know what you're doing.  Thanks for helping Seesthru. 

Just clicked on the left Ouro and had to reboot the page for it to go away.  Didn't realize it was the sound, thought it was just the Ouro.  How do we delete it if we change our mind and don't want it in the post?   What does the right one do?  I am not clicking on it.

Share this post


Link to post
Share on other sites

Hi,

One button produces a single, the other a double boom sound effect to insert into your post. I was intending to add a different icon with a x2 but that's on hold because for now, I don't see a way for this to work for non-admin accounts that can't post html. I'll keep looking into it but I may have to just remove the buttons.

You can probably just delete it from a post if you've tried it.

(If you want to know more...)

I basically made a custom button for CKEditor that has this icon and produces this snippet of code, it inserts this source code snippet (which is the HTML5 audio tag with the option to display the playback controls), into a post. You/I would have to click on the source button in the editor to see the html that is actually produced to make up the post, but non-admin accounts won't see it, since html posting is restricted to protect against hacking.

So if you were to see the code it would look like this..

<audio controls="">
		<source src="https://millennium-thisiswhoweare.net/downloads/audio/effects/MD2_single.mp3" type="audio/mpeg"> Sorry, your browser does not support the audio element.
	</audio>

The text editor (actually CKEditor) interprets that code to display the playback controls, which start the sound when used, otherwise you'd hear the sound as the page loads but no controls would show. 

However, what is happening for you guys is that the code is being stripped out when you hit the Submit button, so it's not displaying and working correctly for you. :blink:

 

  • Like 1

Share this post


Link to post
Share on other sites

Glad you explained it in simple terms at the end.  I got lost in the middle.  :huh:

  • Like 1

Share this post


Link to post
Share on other sites

Regarding the Millennium Windows 7 Theme you were discussing, just a thought but I'm not sure it will install and work properly in Windows 10. The way desktop themes in Win 10 probably changed, so you may just see the background image that comes with it, but get no sound effects unless you manually add them.

I'll have to make a Win 10 version if nobody else does, it would be nice to have.

  • Like 1

Share this post


Link to post
Share on other sites

A win 10 would be nice to have!

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.